Announcement

Collapse
No announcement yet.

Wake on Lan - Wake on Wan on a linksys

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wake on Lan - Wake on Wan on a linksys

    I will try to summarize this quickly.

    Due to the computer being turned off, the ARP info in the router is flushed, therefore the MAC address / IP Address pairing is gone. (i think i explained that right)

    So anyway, in order to get WOW working properly, I would have to port forward to my broadcast IP (192.168.1.255).

    Unfortunately linksys doesnt let you use 255 and the only work around I have seen is to use DDWRT. Too bad my router doesnt support it.

    So the question is, is there a workaround for this limitation? Is there a way to inject code that will trick the router into letting me use 255? The router page is written in ASP...which i guess is javascript?

    This is for the most techy of guys here
    Last edited by dragonash; 04-12-2010, 08:43 PM.

  • #2
    ASP is most commonly written in VB, but can also be C#.

    Outside of that, I can be little help as I have little experience with WoL or WoW.
    For all the reasons to smile, 'for the hell of it' has always been my favorite.

    Comment


    • #3
      This confuses me greatly.

      Why would you port forward your broadcast IP? Is such a thing even possible? Its not an address that can be assigned to a system. Do you only have one system on your LAN that needs WOW access? (Never played it - don't know what the technical requirements are.)

      Is it an issue of the computer's IP address being DHCP and possibly changing? If that is the case you can either assign your computer a static IP or you should be able to set up an IP reservation for your computer's MAC address in the router's DHCP service so that your computer is the only one that will be assigned that IP. In either case, you can set up the port forwarding on that known IP address.

      Comment


      • #4
        Originally posted by Saboteur View Post
        This confuses me greatly.

        Why would you port forward your broadcast IP? Is such a thing even possible? Its not an address that can be assigned to a system. Do you only have one system on your LAN that needs WOW access? (Never played it - don't know what the technical requirements are.)

        Is it an issue of the computer's IP address being DHCP and possibly changing? If that is the case you can either assign your computer a static IP or you should be able to set up an IP reservation for your computer's MAC address in the router's DHCP service so that your computer is the only one that will be assigned that IP. In either case, you can set up the port forwarding on that known IP address.
        I missed something.
        Do you think im playing World of Warcraft? Or were you just joking around lol.

        Anyway, Im trying to get Wake on Wan working and a large portion of my reference material has come from this site, mainly because they have the same issue
        http://forums.whirlpool.net.au/forum...fm/833973.html
        Last edited by dragonash; 04-13-2010, 01:42 PM.

        Comment


        • #5
          Oh. Well that's very different.

          Never mind.

          Comment


          • #6
            Sounds like the solution is here:

            Some routers donít allow broadcast IPs to be used as a target IP. This is where having Static DHCP comes in handy. If you have configured Static DHCP, and your router has the MAC of your target PC, you can configure your router to forward the WOL packet directly to the IP address of the target PC.
            Read http://www.smallnetbuilder.com/content/view/29941/53/

            especially steps 5 and 6.

            g/l
            National Sarcasm Society
            "Like we need your support."

            Comment


            • #7
              Originally posted by Saboteur View Post
              Oh. Well that's very different.

              Never mind.


              You get a free pass this time. This IS primarily a gaming forum after all.
              National Sarcasm Society
              "Like we need your support."

              Comment


              • #8
                It is SO easy to confuse DA with Musky anyway!!!!

                Comment


                • #9
                  Originally posted by Dr. Death View Post
                  Sounds like the solution is here:



                  Read http://www.smallnetbuilder.com/content/view/29941/53/

                  especially steps 5 and 6.

                  g/l
                  but i have my computers nic set to a static IP already. Are you saying that is different from setting it within the router?
                  Regardless, i can give it a shot.

                  edit:
                  I think I'm starting to get it a bit now. Because the mac is now manually saved in the router along with the IP it needs to point to, I shouldn't have to worry about the ARP refreshing
                  Last edited by dragonash; 04-14-2010, 11:27 AM.

                  Comment


                  • #10
                    Hey! I *did* suggest having a DHCP reservation in your router for your PCs MAC address!

                    cue The Todd: Blind-squirrel-finding-a-nut five!

                    Comment


                    • #11
                      yes you did

                      I haven't tested it yet, so I am waiting to find out. I wasn't understanding the difference between a DHCP reservation and just assigning a static IP on the nic.

                      edit:

                      no dice.

                      It sounded like it should have worked, but didn't.
                      Last edited by dragonash; 04-14-2010, 01:16 PM.

                      Comment


                      • #12
                        Did you test it in stages like the article suggested?

                        1. Test WOL from inside the router to make sure that the computer is properly set to wake up.

                        2. Test from outside and monitor with Ethereal or another tool to make sure the WOL packets are being properly routed to the computer.
                        National Sarcasm Society
                        "Like we need your support."

                        Comment


                        • #13
                          The difference is that the computer will always receive the same IP address from the DHCP server, but other stuff such as the latest DNS server assignments are dynamic. Also I believe the article noted that you can't use WOL from a wireless NIC. You are using wired right?
                          National Sarcasm Society
                          "Like we need your support."

                          Comment


                          • #14
                            The tests have all been done prior to this last configuration.

                            WOL works perfectly.
                            WOW only works for about 5 minutes after the comp is turned off.
                            Supposedly the problem happens when the router refreshed the ARP info.

                            Correct, I am using a wired nic.
                            I guess the one bonus about this new router is that is has some additional diagnostic capabilities.

                            I checked the log and it seems I am hitting the router, but it's blocking it...i think

                            Source IP Address Destination Port Number

                            xxx.xxx.xxx.xxx (censored the ip): discard

                            now that looks odd.
                            So I decided to turn off the firewall on the router along with disabling the "filter anonymous internet requests" option, hoping for the best.

                            I still get that discard log file.
                            I have the static DHCP IP set to 192.168.1.25 and i also have UDP port 9 forwarded to that IP as well.

                            Any ideas?

                            edit:
                            my old router didnt have DDNS, but noticed this did, so i just signed up for dyndns and applied it to my router instead of using no-ip.org.
                            Last edited by dragonash; 04-14-2010, 03:29 PM.

                            Comment


                            • #15
                              Originally posted by dragonash View Post
                              Any ideas?
                              Try a different port number.
                              National Sarcasm Society
                              "Like we need your support."

                              Comment

                              Working...
                              X